Subscribe

Thursday 8th June 2017

systemcheck

Resolved - 15:57:24 Jul 10 UTC


Everything operating normally.


Resolved - 06:46:58 Jun 08 UTC


Everything operating normally.


Partial outage - 06:37:44 Jun 08 UTC


We're investigating increased error rates.