Subscribe

11th September 2017

systemcheck

Resolved - 03:20:48 Sep 28 UTC


Everything operating normally.


Resolved - 13:07:47 Sep 11 UTC


Everything operating normally.


Partial outage - 13:04:29 Sep 11 UTC


We're investigating increased error rates.